一、实验目的

  • 通过三层交换机实现VLAN间互相通信

二、基本技能实验内容、要求和环境

  • 假设某企业有2个主要部门:销售部和技术部,其中销售部门的个人计算机系统分散连接在2台交换机上,他们之间需要相互进行通信,销售部和技术部也需要进行相互通讯,现要在交换机上做适当配置来实现这一目标。
  • 实验拓扑:
    实验拓扑

三、基本技能实验配置与结果分析

【Switch2】

Switch>enable
Switch#conf ter
Switch(config)#vlan 10
Switch(config-vlan)#exit
Switch(config)#interface fastEthernet 0/5
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 10   //将pc0划分到vlan10
Switch(config-if)#exit
Switch(config)#vlan 20
Switch(config-vlan)#exit
Switch(config)#interface fastEthernet 0/10
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 20   //将pc1划分到vlan20
Switch(config-if)#exit
Switch(config)#interface fastEthernet 0/24
Switch(config-if)#switchport mode trunk 
SwitchA(config)# ip routing
SwitchA(config)# interface Vlan 10
SwitchA(config-if)# ip address 192.168.10.254 255.255.255.0
SwitchA(config-if)# no shutdown
SwitchA(config-if)# exit
SwitchA(config)# interface Vlan 20
SwitchA(config-if)# ip address 192.168.20.254 255.255.255.0
SwitchA(config-if)# no shutdown
SwitchA(config-if)# exit

【Switch1】

Switch>enable
Switch#configure terminal
Switch(config)#vlan 10
Switch(config-vlan)#vlan 20
Switch(config-vlan)#exit
Switch(config)#interface fastEthernet 0/5
Switch(config-if)#switchport mode access 
Switch(config-if)#switchport access vlan 10    //将pc2划分到vlan10
Switch(config-if)#exit
Switch(config)#interface fastEthernet 0/24
Switch(config-if)#switchport mode trunk      //将连接交换机的端口设置为Trunk端口 

实验结果:

  • pc0和pc2同处于vlan10,pc1在vlan 20,pc0和pc1和pc3之间都可以能相互通讯。
    实验结果

四、进阶技能的任务与要求

  • 某企业分部的网络,共三台交换机

进阶

根据相关的技术与背景知识,以前面的基本技能训练为基础,并结合所给定换机产品的命令帮助功能,自主完成该网络环境中的VLAN配置,实现全网连通

五、进阶技能实验配置与结果分析

【SwitchA】

Switch>enable 
Switch#conf terminal 
Switch(config)#hostname SwitchA
SwitchA(config)#vlan 10
SwitchA(config-vlan)#name sakes
SwitchA(config-vlan)#exit
SwitchA(config)#interface fastEthernet 0/1
SwitchA(config-if)#switchport mode access 
SwitchA(config-if)#switchport access vlan 10
SwitchA(config-if)#exit
SwitchA(config)#vlan 20
SwitchA(config-vlan)#name nets
SwitchA(config-vlan)#exit
SwitchA(config)#interface fastEthernet 0/2
SwitchA(config-if)#switchport mode access 
SwitchA(config-if)#switchport access vlan 20
SwitchA(config-if)#exit 
SwitchA(config)#interface fastEthernet 0/23
SwitchA(config-if)#switchport mode trunk 
SwitchA(config-if)#exit

【SwitchB】

Switch>enable
Switch#conf ter.
Switch(config)#vlan 20
Switch(config-vlan)#name sales
Switch(config-vlan)#exit
Switch(config)#interface fastEthernet 0/1
Switch(config-if)#switchport mode access 
Switch(config-if)#switchport access vlan 20
Switch(config-if)#exit
Switch(config)#interface fastEthernet 0/24
Switch(config-if)#switchport mode trunk 
Switch(config-if)#

【SwitchC】

Switch>en
Switch#conf t
Switch(config)#vlan 10
Switch(config-vlan)#name sales
Switch(config-vlan)#exit
Switch(config)#interface fastEthernet 0/1
Switch(config-if)#switchport mode access 
Switch(config-if)#switchport access vlan 10
Switch(config-if)#exit
Switch(config)#vlan 20
Switch(config-vlan)#name nets
Switch(config-vlan)#exit
Switch(config)#interface fastEthernet 0/23
Switch(config-if)#switchport trunk encapsulation dot1q 
Switch(config-if)#switchport mode trunk //先配置封装,再设置trunk
Switch(config-if)#exit
Switch(config)#interface fastEthernet 0/24
Switch(config-if)#switchport trunk encapsulation dot1q 
Switch(config-if)#switchport mode trunk //先配置封装,再设置trunk
Switch(config-if)#exit
SwitchA(config)# ip routing
SwitchA(config)# interface Vlan 10 
SwitchA(config-if)# ip address 192.168.10.254 255.255.255.0 
SwitchA(config-if)# no shutdown
SwitchA(config-if)# exit
SwitchA(config)# interface Vlan 20
SwitchA(config-if)# ip address 192.168.20.254 255.255.255.0 
SwitchA(config-if)# no shutdown
SwitchA(config-if)# exit

实验结果

  • pc0和pc1同处于vlan10,pc2和pc3在vlan 20,pc0,pc1,pc2,pc3之间都能相互通讯
    在这里插入图片描述

六、思考题

  • 如果在S3560上不创建vlan20, vlan20内的主机是否能互相ping通?为什么?
    不能,不同vlan就意味着不能通过二层通信。
本文作者:Author:     文章标题:网络-交换机VLAN间通信
本文地址:https://yuaneuro.cn/archives/35.html     
版权说明:若无注明,本文皆为“yuaneuro的小站”原创,转载请保留文章出处。
Last modification:May 4th, 2020 at 02:47 pm